Как сделать в excel нумерация ячеек

Вернемся в нашу полученную таблицу. И посмотрим, что нумерация в ней нам не хватает для полной красоты сюжета?

электронная таблица excel

Правильно, порядковых номеров строк. Вот все хорошо в Excel, кроме автоматического контроля порядковых номеров. Нет в нем этой функции как в Word. А может быть можно с помощью формул это обеспечить? Можно! И давайте сейчас это попробуем сделать.

Поможет нам в этом очень хорошая функция =СЧЁТЗ($B:B5), которую мы должны прописать в ячейке, в которой должен стоять первый номер нашего списка, причем обратите внимание мы должны его еще и закрепить знаком $. И так в ячейке А5 прописываем функцию =СЧЁТЗ($B:B5)

автофильтр в excel

затем скопируем эту формулу во все остальные ячейки.

Заполнение пустых ячеек в списке excel

Вот мы и получили нумерацию строк. Обратите внимание как изменилась наша формула на последней ячейке.

А теперь давайте удалим название города, допустим в ячейке В19.

Заполнение пустых ячеек в списке excel

Что получили? В ячейке А23 порядковый номер уменьшился – это хорошо. А вот в нашей В19 продублировался порядковый номер вышестоящей ячейки, и это не есть хорошо. Значит необходимо ввести в нашу формулу еще одно дополнение, которое будет исключать из списка пустые ячейки. После изменения наша формула примет вот такой вид =ЕСЛИ(ЕПУСТО(B5);"";СЧЁТЗ($B:B5)). Протянем ее вдоль всего столбца А. И в результате получим

Заполнение пустых ячеек в списке excel

То что доктор прописал!!!

Попробуйте теперь удалить или вновь заполнить пустые ячейки. Сами увидите как все работает прекрасно.


Источник: http://excel3161.narod.ru/excel1.html


Рекомендуем посмотреть ещё:


Закрыть ... [X]

Нумерованный список в Excel. Как пронумеровать строки в Excel, Эксель Подарки фото на чашке



Как сделать в excel нумерация ячеек 5 интересных способов как происходит нумерация строк в Excel
Как сделать в excel нумерация ячеек Как в Excel сделать нумерацию строк или столбцов
Как сделать в excel нумерация ячеек Как пронумеровать ячейки в excel (экселе) «
Как сделать в excel нумерация ячеек Автоматическая нумерация ячеек в Excel
Как сделать в excel нумерация ячеек Автоматическая нумерация строк - Excel
Как сделать в excel нумерация ячеек Совет 1: Как в Excel сделать нумерацию
Как сделать нумерацию строк в excel? 7 самых необходимых средств для укладки. Обсуждение на LiveInternet Демченко А.В. Киты по штирборту: Юнец Торгового МКУ ЗАТО Северск Ресурсный центр образования Николай Дубов. Мальчик у моря Открытки m Пожелания друзьям к Рамадану » Поздравляю со священным месяцем

Похожие новости